Android App

Follow

Comments

2 comments

  • Avatar
    Sally Wilkins

    Hmm. I have 4.4 (Kitkat) and the Google store is telling me that the version available is not compatible with my device. Is there some other reason, I wonder?

  • Avatar
    Nikolay Ugarov

    I'm interested in joining mentioned beta..

Article is closed for comments.