Deep Links Opening Externally when Search Terms are Included on Root Node

Comments

6 comments

  • Avatar
    Frank (Workflowy Support)

    Hi Brian.

    The standalone Chrome web app we discontinued years ago. Are you using an app that depends on Chrome or are you talking about workflowy.com?

    0
    Comment actions Permalink
  • Avatar
    Martin Mach

    Hi there, 

    sorry for breaking in :) I have the same problem - manually created search links, see examples from Bryan, are no longer opened in-app. I am using the latest Mac desktop version (1.3.7-2313). It still works on iPad/iOS.

    Looks like an internal app filter - what is going to be opened internally in-app and what in the browser was changed. You can hack&fix this like. eg. https://workflowy.com/#/0?q=%23urgent%20 (I am trying to mimic a subnode link with "0" and it works : ) ). However, I would prefer a proper fix by Workflowy.

    (I understand that this "feature" was probably never advertised, however, there is no better way to link a tag or search on top of a root node, daily planning template with links like eg. https://workflowy.com/#?q=tomorrow is super useful for daily planning.)

    0
    Comment actions Permalink
  • Avatar
    Brian Clements-Tiberio

    Hi Frank,

    This behavior is confirmed on chrome and firefox for workflowy.com. When I was talking about a chrome app, I was referring to basically workflowy.com in chrome browser with the "Create shortcut" and "open as window" behavior when it looks like a standalone app, but it's just really a detached chrome tab. Clicking the deep links with search terms on root node will open up my main chrome window and open the search in a new tab, likewise, in firefox, it will open a new tab there as well if starting from in firefox. This also is true of the desktop appimage. It will open the tab in my "default browser" which I have set to firefox. I'm on Linux too, btw, in case that matters.

    0
    Comment actions Permalink
  • Avatar
    Frank (Workflowy Support)

    Hi folks... so... this has been fixed and will be pushed to production in a day or two. You can test via beta.workflowy.com...

     

    1
    Comment actions Permalink
  • Avatar
    Brian Clements-Tiberio

    Confirmed fixed for me via version 21.11.24.1057. Thanks!

    0
    Comment actions Permalink
  • Avatar
    Martin Mach

    Works for me as well, thank you!

    0
    Comment actions Permalink

Please sign in to leave a comment.